Hattrick Organizer

From Hattrick
Jump to: navigation, search
INTERWIKI

· English · Magyar · Nederlands ·

Hattrick Organizer is the most popular CHPP helper application for Hattrick. It is a java-based and completely free program.

HO-site-splah.gif

Hattrick Organizer (simply called HO) is a very extended helper application created in 2003. It's OpenSource licensed LGPL since 2006 and written in Java, therefore it's OS independent. Installers for Windows and MacOS are supplied, as well as a ZIP file for every other platform (Linux, BSD, Android, ...).

Contents

Installation

First historical HO start screen
  • Download installation file (see links)
  • You'll now get a small window, click Save
  • You might now get a securitywarning. Just continue
  • Now just follow the steps and save the file in C:\HattrickOrganizer to avoid problems in the future.

If you let the program install a shortcut on your desktop, open HO that way. Else, go to the folder in which you installed HO and you will see a file called ‘HO’. Open this file and you’re off!

First Startup

New HO start screen version

Everytime you start up HO, just let Java do its job and wait a little. Depending on the databasevolume this might take a while.

When you start up the program for the first time, you will have to choose the language. This can be changed later on.

When HO has started up, you have to download your data from Hattrick. This can be done by going to

File --> Download. 

Now, you first have to give permission to HO to download the needed data.

Click Open URL. 

The CHPP-page of Hattrick will open and you'll see a long code. Copy this code and paste it in the textbox in HO. Now click Enter.

After HO made a connection to Hattrick, you have to choose where HO has to save your data. Choose a location and click Save. HO will now download all data and save it on the chosen location as an HRF-file.

When this is all done, HO has all the data it needs and you are ready to explore the remainder of the program. But remember, to use HO optimally, you'll have to download your data regularly!

Menu

File

Download (F11)

Let’s start with the most important thing. How to get all the information in HO? Very simple. When you go to

File --> Download

you'll see the download-screen. All you need to do is click the Download-button. If you also want information from the past, you can do that on the right by choosing a particular season or by selecting a specific date.

You'll get the Export-screen. Here you can choose where on your computer you want to store the data. When you're done, you can click Save. When this is done you are ready. HO will now download and store all data as a HRF-file, and all information will be in the right place within the program.

Downloading all data is something you do best at least once every week after the training update.

Import HRF

If you realize some HRF-files from the past are missing in the list at the bottom right corner of the Squad tab, you can choose to import them.

Through

File --> Import HRF 

you can choose the folder where the HRF is stored and you can load that file. When importing multiple files, they will be loaded in the order they are selected in. So be careful to select the oldest file first!

Refresh

After changing some things manually, changes can be activated here. This goes from the flag collection to ratings. A restart will probably be required.

Calculate Subskills

This (re)calculates the subskills for the full data history.

Calculate Subskills (7 weeks)

This (re)calculates the subskills based on the datasets of the last 7 weeks. This option is much quicker if you have a large database or a slow computer.

Options

This is where changes in formulas, layout, … can be made.

  • In the tab Misc you can change the language, choose how the skills are displayed, choose how HO sorts the players, ...
  • In the tab Modules you can choose which tabs should be visible at startup.
  • In the tab Colors you determine what color specific players appear in.
  • In the tab Formulas’ you can set for yourself the contribution of a certain position. You better don't touch this if you don't know exactly what you are doing.
  • In the tab Prediction Offset you can manually change the predicted ratings for an already played match. If you want the ratings to get perfectly fine, you better do this several matches in succession.
  • In the tab Training HO stores how long it takes to increase a skill. The values in HO happen to be a little to low, so don’t be disappointed if it takes longer than expected to increase a skill.
  • In the tab HO Check you can decide which checks HO should perform.
  • In the tab Download you can set which data HO should download. You can also change this when downloading.
  • In the tab ‘Columns’ you can choose which columns HO will display in the Squad tab.

Database

Options gives you the possibility to add an extra user.

Cleanup HO Database lets you decide which matches are kept in the database. Choose which matches can stay there and which are useless. You can also choose just to keep one HRF-file per week.

Full Screen (Shift + F11)

This makes HO use the entire screen. To deactivate, press F11 again.

Exit

This requires little explanation. The program will be closed.

Functions (or Tabs)

By default, not all tabs are visible. Tabs can be added through

File --> Options --> Modules.

Squad (F1)

Through Functions --> Squad you go to the Squad tab.

This tab contains all information about your players. The tab is divided into three smaller boxes.

The larger box contains everything related to the skills and performance of your players. By going over the column titles with your cursor, you can see what the abbreviations stand for.

HO-players.jpg

The values in the columns represent the skills. (…, 6=passable, 7=solid, …). A skill increase is indicated by a green arrow, a skill drop by a red arrow. The color of the player’s name tells you the status of that player, such as injured, suspended, … To change these colors or to see their meaning, go to

File --> Options --> Colors.

The last column gives you a market value of a player. You'd better not look at this because the values are the results of some very old formulas. The market value HO give you isn't realistic and in fact only has some nostalgic value.

The left box shows the details of the selected player.

Through the first three buttons you can load the player into the ‘Statistics’-tab (1st button), on top in the Player Analysis-tab (2nd button) or at the bottom of the ‘Player Analysis-tab (3th button). The 4th button gives you the chance to change a player’s subskill in HO.

If you know his subskill, this can make HO's predictions a lot better. Through the last button, you can exclude a player from training.

In the Skilltester-tab you can see how good a player would be with certain skills. You can also add modifications. The next time you start HO, the changes are gone.

The box on the right of the screen contains all the downloaded HRF-files. By clicking one of them you can see all changes since that HRF was downloaded.

Above the HRF-files are fourteen colored buttons. These can be used to allocate a player to a certain squad (A-squad, B-squad, ...).

For example: to put all A-players in the B-squad, click A in the top row and B in the bottom row. Then click the arrow. All involved players will now have a new letter behind their name.

Lineup (F2)

Through Functions --> Lineup you go to the ‘Lineup tab.

This tab is were you can make your lineup. The tab is divided into four boxes.

This time we start at the bottom, with the big box. This contains the same information as the Squad-tab. So, nothing special.

In the box on the right you can choose which players are allowed in the lineup. You can also see which player is the best in a possible penalty shootout and you can let HO make a lineup for you. Remember that HO can’t take into account any of your opponent’s tactics. This means the lineup HO gives, isn’t necessarily the best one. By going over an option with your cursor, you get to see the explanation.

Now that the lower two boxes are discussed, we return to the top. In the big box you see room to make a lineup. By using the dropdown lists you can choose your players and you can give them an order. Besides the players name and his order, you can see the estimated number of stars that player will get. The green arrows make two players swap places. Through the small buttons on the right you can assign your whole lineup to a specific squad.

The last box to discuss is on the right. Here you can see the estimated rating you will get with the given lineup. The rating also contains other settings like confidence, team spirit, …

By choosing a tactic in the second dropdown menu you get to see the tactic skill. It is known that the prediction for Long Shots isn't accurate at all. You better use our own tool for this.

The second and third tab gives you the chance to give in some substitutions and your penalty takers. The last tab let's you upload your lineup to the chosen match within Hattrick.

The most logical step after determining a lineup, is comparing it with your opponent. This can be done through the "TeamAnalyzer" (see further).

League Details (F3)

Through Functions --> League Details you go to the League Details tab.

In the League details-tab the standings and schedule can be found. Also some statistics like Who is the best team in their own stadium and Who scored the most away goals are provide here. This is also where you can download matches from the other teams in your league.

Matches (F4)

Through Functions --> Matches you go to the Matches tab.

Here are the match reports from both your own team, your next opponent as extra downloaded matches. If you are happy with a specific lineup from one of these matches, then click the right button to load that lineup into the Lineup-tab.

This tab also provides you some statistics about the different types of games. Loading might take a while.

Player Analysis (F5)

Through Functions --> Player Analysis you go to the ‘Player Analysis tab.

In the Player Analysis-tab you can easily compare two players. Weather, tactics, confidence, … are also taken into account.

Statistics (F6)

Through Functions --> Statistics you go to the Statistics tab.

On this tab you can see the evolution of a player, the ratings, finances, … On the left you can choose which period you want to see the data from and you can choose the data you want to see.

The values used in the Player-tab are the same value as in the Squad-tab.

The values used in the Matches-tab are the same values as the values that can be found on the right in the Lineup-tab after making a lineup.

The values in the tab ‘Team are the averages of the entire team.

The Arena-tab gives you an overview of how many spectators were present during the requested matches. When you notice you sold out a couple of times, it is probably time to expand your stadium.

Transfers (F7)

Through Functions --> Transfers you go to the Transfer scout tab.

The first tab gives you an overview off all your transfers. You can also see them per season. You can also re-download your transfer history here. This is best only done if the data in HO is incorrect or incomplete.

The Transfer Types-tab gives you a list of how much you have already spent on a certain kind of transfer. HO automatically classifies your transfers in a specific category. These categories are pretty often wrong, so if you want a nice overview you will have to change it by yourself.

In the last tab you can fabricate players. Enter all details and click ‘Add’. When you do this with multiple players, you can compare them in the upper part of the screen. You can also temporarily add a player to you team by clicking ‘Add player. After doing this, the players will appear in the list on the Squad-tab. You can now add him to your lineup if wanted. This way you can see what effect this player would have on your ratings.

After closing HO, the added player will have disappeared, though he will still be in the list on the Transfer Scout tab.

Training (F8)

Through Functions --> Training you go to the Training tab.

In this tab you best start by setting your future training. You can do this by clicking Set All on the right and choosing training for the next 16 weeks. If you know your training will change during this period, you will have to set it week per week.

The Training-tab shows you how far the players are trained in their skill. These are the same values as on the ‘Squad’-tab.

The Prediction-tab gives you a prediction of when a player’s skill will raise based on the set training. Because a lot of managers like to sell their players after a skill raise, but before their birthday, HO also shows their next birthday.

The ‘Analyzer’-section gives you an overview of all skill, stamina and experience increases.

In the Effect-tab you can weekly see the effect the training had on TSI, form, and of course the skills of the players.

Misc (F9)

Through Functions --> Misc you go to the Misc tab.

All information about your team on one page.

TeamAnalyzer (F10)

To use this, you first have to make a lineup in the ‘Lineup’-tab.

First you will have to choose which opponent you want to compare your lineup with. Due to CHPP-restrictions, HO can only predict two games ahead. Your opponent during the week is marked in green, the next league-opponent is in red.

After this you click Update so HO can load the matches. Now you can choose which matches you want to use in the analyzer.

Once you have done this, you can click the Analyse-button. Some data appears in the small box under the button. These are the average ratings of your opponent during the selected matches. The difference compared to your ratings will be indicated with arrows (see image). A green arrow with a 5 in it means that your rating is five sublevels higher your opponent’s rating.

If needed, you can now let HO simulate the match based on the ratings of both teams. After clicking the ‘Simulate’-button you will see that in the white box a lot of numbers appear.

The upper numbers indicate the number of simulated matches won by the home team, visitors and how many matches have ended in a draw. The bars contain the same numbers in percentages.

Below is the distribution of the chances during all the simulated matches. Between brackets you can see the number of chances a team had during the simulated matches. The number outside the brackets is the number of scored goals during the matches. The bars contain the percentages again. Using these data you can try to find out how to beat your opponent.

Plugins (Ctrl+#)

If you add new plugins to the basic program they will be shown here. There are a lot of interesting add-ons like team spirit forecast or analyzer of cards and special events, flag chasing tool, etc...


Go to the FAQ for more information about these subjects.

Tools

Arena sizer

Fill in the wanted size and click Calculate to see how much income and costs would differ compared to the actual size of your stadium. Since version 1.432 the arena sizer uses (approximately) the optimal distribution.

Keeper tool

The Keeper tool helps you determine your keeper's skill. In Manual you can calculate this using the TSI-form combination. Under 'The Player you can choose a keeper in the list.

Injury calculator

First, select an injured player in the row. Now you can calculate how many updates it takes for an injured player to be able to play again. You can do this in several ways:

  • With the number of doctors you can calculate how long it will take to heal.
  • With the number of updates you can calculate how many doctors are needed.
  • Through the daily TSI-rise, the number of needed updates can be calculated.

XML Exporter

This is where you can let HO convert all of your team data to an XML file. There are problems known from the past so it is possible that the exporter doesn’t work properly.

CSV PlayerExport

Here you can convert all of your team data to a CSV file. This can be used to create statistics and save them. You can for example export the data to Excel and work with it.

Notes

Here you can type whatever you want, going from Hattrick related stuff to a shopping list.

HRF-Explorer

This is where you get an overview of the saved HRF-files. You can also see their contents and delete them if you want.

Modules

TeamAnalyzer

Here you can download matches you want to use in the Analyzer.

NTHRF

Click here to download your national team's data. This module can be used by elected NT/U20 managers only.

NEVER import any NT HRF files into your normal HO and use a secondary installation only!

About

HO! Homepage

This opens the HO-website.

HO! Forum

This opens the HO-forum. There isn’t much activity but developers still answer some questions occasionally.

www.hattrick.org

This opens the Hattrick-website.

Help

This opens a brief manual.

Credits

A list of all who helped creating the program.

2003 development was started by Thomas Werth and Volk Fisher. Since 2006 the project is OpenSource and developed by changing developers.

Frequently Asked Questions

My HO keeps getting slower. What’s the reason and how can I fix it?

After some time HO may become slower if often used. The two reasons are:

the size of the database. HO loads everything at startup and writes everything away when you exit;
the number of created HRF datasets with each download. The more datasets, the more calculations are being made

To reduce the database size without losing data, you can delete all matches not related to your team. If you regularly use the Team Analyzer there will be many such matches. Go to the Matches-tab and select Show other teams' matches. With the red cross at the bottom you can remove matches. By pressing CTRL while clicking, you can select multiple matches.

If you want to reduce the number of HRF-datasets, you can use the HRF Explorer (Tools --> HRF-Explorer). In theory you can also use the list on the ‘Squad’-tab but het HRF Explorer gives a better overview. Navigate through the calendar and if you have more than one HRF per week, you can remove some if you need to.


How can I change the language?

You can change the language via

File --> Options --> General

Restart is required.

Installation

How can I update HO without losing my data?
It is recommended to take a copy of your data before the update.

There are several ways to update HO:

  • extract the zip-file in the existing HO folder (=overwriting files);
  • install the new HO in the same folder as the old one;
  • install in a new folder and copy the db-folder of the old HO to the new location;
  • install in a new folder, import the old HRF-files, download old games, recalculate sub skills, …

... but the easiest way is to use the internal update mechanism, via

File --> Update --> HO

If a new version is available, a dialog will emerge where you have to click ‘Yes. If nothing happens, you already have the latest version.

If everything went right you should get a message saying you need to restart HO.

Tab Lineup

Some players are not in the list. What’s the reason?

At the bottom right of the screen you can exclude certain players from the list. There is probably something clicked.


What is the SubTeam spirit and how can you know it?

The SubTeam spirit is the team spirit after the comma, just like skills also have a subskill. By default the team spirit is Composed (average). That may change by playing Match Of The Season or Play It Cool or by transferring players. If you know the team spirit was higher than composed and on a morning you see a return to composed, then you know the SubTeam spirit is Very high’. The other way and other levels is of course the same explanation.

Tab Matches

How can I simulate a match against a team that is not in my division?

First you will have to add the other team to HO via

Modules --> TeamAnalyzer --> Favourite --> Add

Once you have done this you can download a match using the match-id through

Modules --> TeamAnalyzer --> Download a match

That match should now be added to the Matches-tab (if you display all matches). Through the TeamAnalyzer’ you can now simulate a match against this team.

Tab TeamAnalyzer

What is the slider that goes from 0 to 100 for?

The slider determines how many games will be simulated based on the given ratings. 0% means 1 000 simulated games, with 100% there will be 101 000 simulated matches. (This means the formula is Number of matches = (%*1 000)+1 000)

The ratings HO predicted don't match the actual ratings.

HO uses the average ratings of the games you gave the program. A small deviation is always possible but if the predicted ratings are totally wrong, this has probable something to do you’re your opponent not playing the same as in the used matches.


HO gave me 80% chance of winning but still I lost!

As explained above, the unpredictability of your opponent can provide some surprising results, so a game which at first sight was in your favor is suddenly not so easy to win.

Another thing is that Hattrick mainly exists of probabilities. 80% probability of winning still means 20% probability of losing. These are things you can’t do anything about as a manager.

Tab Training Experience

Not all my trained players are in the list while some players I don’t train are. What’s the reason and what can I do about it?

HO lists the players who already have increased their skill. It is therefore possible that other players than the ones you actually train appear in the list. If you only want you trainees to be in the list you will have to change every player'’s Best Position in the bottom part of the ‘Squad-tab (for a playmaking trainer this means you have to add all central midfielders and wingers to the list).

Links

Download

External links